Extruder Nozzle / Düse kalibrieren

Ich wollte heute das erste Mal nach dem Update auf Sailfish 7.4 den zweiten (linken) Extruder ausprobieren, da rauscht mir der Druckkopf in die rechte vordere Ecke des Gerätes, anstatt in der linken vorderen auf den Druckstart zu warten. Die Lösung ist die Korrektur des „X toolhead offset“ in den „Oboard Preferences“. Bei mir Stand ein Wert von 31,818. Laut verschiedenen Posts soll man folgendes rechnen: 33 – 31,818 = 1,182. Diesen Wert als neuen „X toolhead offset“ eingetragen und auf „Commit“ geklickt hilft.

Dazu habe ich noch folgendes gefunden:

The default values should be
X Home around 152 mm
Y Home around  75 mm for a dual, or 72 mm for a single
Z Home around   0 mm
X Toolhead offset around 0 mm or 33 mm [can be either, Sailfish doesn't care]
Y Toolhead offset around 0 mm
Z Toolhead offset around 0 mm (if it even appears -- it's ignored in the code)

Allerdings sind beide Düsen nicht zueinander ausgerichtet. Lasse ich die erste Schicht eines 20mm Cubes zuerst rechts und dann links drucken, liegen die Quadrate nicht übereinander:

IMG_8968

Hier ist das Script für die Düsen-Kalibrierung beim Replicator 1 Dual, welches für den Flashforge Creator passt. Ich finde es im ReplicatorG nicht. 

Ich habe soeben festgestellt, dass ich das falsche ReplicatorG 0040 verwendet habe *facepalm* Jetzt mit dem ReplicatorG 0040-sailfish gibt es auch das „Replicator 1 Dual Nozzle Calibration.gcode“ unter „File->Scripts->Calibration->Replicator 1, 2 & 2x“. Mit der Ausführung dieses Scripts werden auf der Y- und dann auf der X-Achse 14 Linien zuerst vom rechten und dann vom linken Extruder gedruckt.

Die Nummer der beiden Linien merken, bei denen der Druck von links und rechts bzw. oben und unten am genausten gegenüber liegen. Die längere Linie ist dabei jeweils die Linie Nummer 1.

Dann im Creator die Funktion „Utilities->Calibrate Nozzles“ auswählen und die Koordinaten der besten Linienübereinstimmung angeben.

Dummerweise ändert die Eingabe gar nichts 🙁 Ich weiß nicht, was ich falsch mache. Egal, welche Linienkoordinaten ich eingebe, sieht das Druckbild danach genauso aus, wie vorher.

Durch das korrekte ReplicatorG 0040r70-sailfish mit Sailfish-v7.4.0-r1062 steht nun übrigens in den Offsets etwas anderes, nachdem ich den „Reset motherboard to factory settings“ Schritt gemacht habe:

X home offset: 151,998
Y home offset: 74,995
Z home offset: 0
A home offset: 0
B home offset: 0
X toolhead offset: -0,542
Y toolhead offset: -2,411
Z toolhead offset: 0

Zwischenzeitlich war der Mittelpunkt für beide Extruder total verstellt. Der „Wartepunkt“ vor dem Druckstart lag nicht mehr in der linken vorderen Ecke, sondern praktisch in der Mitte des HBP. Geholfen hat da nur ein „reset motherboard to factory settings“ per ReplicatorG Machine->Onboard Preferences. Ein einfaches Aus-/Anschalten hat da nicht geholfen.

[UPDATE 23.06.2013]

Der Kollege vom x90cr Blog liefert die Lösung zum Düsen-Kalibrierungs-Problem – besten Dank!

Nach zweimaligem Testausdruck habe ich eine gute Einstellung mit X toolhead offset = -0,797 und Y toolhead offset =1,009 gefunden.

Das Ergebnis der Bemühungen läßt sich beim Druck des Makerbot-Cupcakes bewundern.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.